Скачать Купить

Вкладка «Выполнение процедуры» для задачи
Вызов Процедур 1С:Предприятия 8

«Процедура:»

  • «Выполнение обмена»
    Вызов процедуры выполнения обмена данных
    «ВыполнитьОбменДаннымиДляНастройкиАвтоматическогоОбменаДанными(КодНастройки)»
    общего модуля «МодульРегламентныхЗаданий».

    В качестве параметра передается код элемента справочника «Настройки выполнения обмена». Работает с типовыми конфигурациями (не управляемое приложение).

  • «Выполнение обмена для конфигурации управляемого приложения»
    Вызов процедуры выполнения обмена данных
    «ВыполнитьОбменДаннымиПоРегламентномуЗаданию(КодСценарияОбмена)» общего модуля «ОбменДаннымиСервер».

    В качестве параметра КодСценарияОбмена — Строка — код элемента справочника «Сценарии обменов данными», для которого будет выполнен обмен данными. Работает с типовыми конфигурациями реализованными как управляемое приложение.

  • «Обмен с WEB-сайтом»
    Вызов процедуры выполнения обмена данных «ЗаданиеОбменССайтом(КодНастройки)»
    общего модуля «ПроцедурыОбменаССайтом».

    В качестве параметра передается код элемента справочника «Настройки обмена с WEB-сайтом».

  • «Обмен с WEB-сайтом для конфигурации управляемого приложения»
    Вызов процедуры выполнения обмена данных «ЗаданиеВыполнитьОбмен(КодНастройки)»
    общего модуля «ОбменаССайтомСобытия».

    В качестве параметра передается код настройки обмена из «Узлы обмена с сайтом».

  • «Выполнить фрагмент кода»
    Вызов экспортной процедуры «ВыполнитьКод(ФрагментКода)» общего модуля EffectorSaver.
    Требуется доработка конфигурации. Подробности в справке.

    В качестве параметра передается фрагмент кода (имя процедуры) на встроенном языке который необходимо выполнить.

  • «Вычислить фрагмент кода»
    Вызов экспортной функции «ВычислитьКод(ФрагментКода)» общего модуля EffectorSaver.
    Требуется доработка конфигурации. Подробности в справке.

    В качестве параметра передается фрагмент кода (имя функции) на встроенном языке который необходимо выполнить.
    Возвращенное значение будет записано в журнал. Значение возврата 0 (ноль) рассматривается как ошибка выполнения задачи.

«Код настройки:/Выполнить код:»
Для процедур выполнения обмена, в качестве кода настройки необходимо указать код элемента справочника соответствующей настройки.
Для «Выполнить фрагмент кода»/«Вычислить фрагмент кода» в параметре указывается полностью строка запуска процедуры/функции с параметрами.

Доработка конфигурации

1. В конфигурации добавьте общий модуль
Имя: EffectorSaver
Клиент = Истина
Сервер = Истина
Внешнее соединение = Истина

dorabotka-konfiguracii-1С-dobavit-obshhij-modul

2. В теле модуля вставьте следующий текст

Процедура ВыполнитьКод (ФрагментКода) Экспорт

Выполнить (ФрагментКода);

КонецПроцедуры

 

Функция ВычислитьКод (ФрагментКода) Экспорт

Рез = «»;

Выполнить(«Рез=»+ ФрагментКода);

Возврат Рез;

КонецФункции

 

Функция Тест() Экспорт

Возврат («Тест вызова функции»);

КонецФункции

dorabotka-konfiguracii-obshhij-modul

Проверка

Создайте новую задачу «Вызов процедур 1С:Предприятия 8».

Настройте подключение к базе.

В поле «Процедура:» установите «Вычислить фрагмент кода».

В поле «Выполнить код:» вставьте EffectorSaver.Тест()

Сохраните задачу. Выберите Меню «Задачи» — «Выполнить сейчас».

В журнале должна появиться запись с содержимым: «Значение возврата: Тест вызова функции».

Статьи и документация